Opened 13 months ago

Last modified 6 months ago

#1214 reopened defect

MSN no longer working

Reported by: Jojo Owned by: leecher
Priority: major Milestone:
Component: msn Version: 0.95.5
Severity: bug Keywords:
Cc:

Description

After MSN stopped working in the latest stable version a long while ago, I have recently updated to the latest development version - and lo and behold, I could log into my MSN account again! However, MSN login fails again since a few days ago. It tries to connect for five seconds or so and then goes back to offline. Is this a known problem?

Attachments (3)

netlog.7z (10.0 KB) - added by Jojo 13 months ago.
netlog.2.7z (7.2 KB) - added by Jojo 13 months ago.
netlog.txt (22.6 KB) - added by Tragen 10 months ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 13 months ago by wishmaster

Yes, it is known, you can use Skylogon from here

comment:2 Changed 13 months ago by wishmaster

Skylogon was merged in r16512, no external DLL needed anymore.

comment:3 Changed 13 months ago by Jojo

I updated to the latest development version, but I still can't login. Do I need to change anything else?

comment:4 Changed 13 months ago by leecher

Ensure that you have OpenSSL libraries installed which are needed for Skylogon method. Other logon methods don't seem to work anymore (but still exist as fallback in the code).

comment:5 Changed 13 months ago by wishmaster

OpenSSL download links can be found here:
http://wiki.miranda-ng.org/index.php?title=Plugin:OpenSSL/en
("no external DLL needed anymore" was a bit misleading, I guess...)

comment:6 Changed 13 months ago by Jojo

It seems like my OpenSSL setup is working (see #1210), but MSN connections still fail. :\

comment:7 Changed 13 months ago by leecher

Please attach netlog.

Changed 13 months ago by Jojo

comment:8 Changed 13 months ago by Jojo

Netlog attached. I'm not sure if it's related, but with the OpenSSL plugin enabled, Miranda constantly eats a whole CPU core here.

comment:9 Changed 13 months ago by leecher

Current build now contains some SkyLogin? logging too, maybe that helps finding the problem. Can you please retry with new build and attach netlog again?

Changed 13 months ago by Jojo

comment:10 Changed 13 months ago by Jojo

New netlog added, sorry for the delay.

comment:11 Changed 11 months ago by Jojo

This problem persists in the latest development versions.

comment:12 Changed 11 months ago by leecher

  • Resolution set to worksforme
  • Status changed from new to closed

Not reproducable for me, someone who can reproduce the problem needs to take the ticket and fix this pls.

comment:13 Changed 11 months ago by Jojo

Since the issue is still present, it should remain open and not be closed, I guess?

I really wonder that the netlog says "Login Failed.. Bad Credentials.." - because the credentials are definitely correct. In fact, if I deliberately enter wrong credentials, I get a completely different behaviour, namely a Live login window that tells me that the credentials are wrong.

comment:14 Changed 11 months ago by leecher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

You are right, closing was a mistake, reopened it.. I just wanted to remove myself as owner, as I'm unable to fix an error that cannot be reproduced on any of my machines with different test accounts. Maybe it's specific to your account or machine, you can experiment a bit, i.e. try 32bit and 64bit version of Miranda, with a completely clean profile, on different machines, etc. Maybe there is some pattern? Or maybe it's somehow related to your account, I don't know.

The different behaviour you get with bogus login data is because the first step is to log you in via OAuth and this generates a token that then gets used for login on Skype Login servers where the request fails for some unknown reason.
So I don't have a doubt that you login data is correct, but it's unknown to me why the Skype Login server communication fails for you whereas it always works for me. There are some machine specific parameters that get calculated in login code. I don't think that they are somehow checked by the login server, but who knows... Therefore, maybe it's machine or profile related because of these parameters, it could also be related to the account, openSSL libraries, etc. There are dozens of possibilities, unfortunately. Therefore examination should be done by a developer who can somehow reproduce the problem on his machines.

comment:15 Changed 10 months ago by robyer

@leecher: About reproducing - for Facebook protocol I often ask the user to borrow me his credentials (with changed password). Maybe @JoJo? will be willing to help you this way too?

comment:16 Changed 10 months ago by leecher

@robyer: I don't even think it's account related, I got reports that it works with the same account on different machines whereas on others it doesn't.
Logon server says no, so I don't think that this can be fixed without the logon server telling the reason of denial which it doesn't tell us.
Alternative Web logon is no more, so I guess we have to live with it that it works for some users on some machines and for some it doesn't. But ppl. who can reproduce it are invited to fix it and submit patches, of course.

What can be tried is to fetch an older version from SVN repo which relied on Skylogon.dll and check if it works with the DLL, then linking in the code may be the reason for failure.

Changed 10 months ago by Tragen

comment:17 Changed 10 months ago by Tragen

I have attached my netlog.txt
I hope it helps. I cannot debug this problem as I don't have any C++ experience but I'm willing to do what you need.

Last edited 10 months ago by Tragen (previous) (diff)

comment:18 Changed 7 months ago by Jojo

MSN randomly started working again a few days ago. I guess you can close this ticket.

comment:19 Changed 7 months ago by Jojo

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:20 Changed 6 months ago by Tomaso

Nope.
Still not working for me.

comment:21 Changed 6 months ago by Tomaso

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:22 Changed 6 months ago by robyer

We don't use Trac and issues here as we moved to Github - https://github.com/miranda-ng/miranda-ng/issues

You might need to create new issue there as there are not imported all closed ones.

Note: See TracTickets for help on using tickets.